Grid

698 - Grid not appearing during combat when layout was None

Grid version:

5.2.0.1600

WoW version and region/language:

5.3 enGB

Steps to reproduce the problem:

  1. Don't be in group.
  2. Enter combat.
  3. Join group.

What you expected to happen:

Grid appearing.

What actually happened:

Nothing. (including no errors)

Does the problem still happen when all other addons — including all Grid plugins — are disabled?

Yes.

Does the problem still happen after you switch to a new profile in Grid with default settings, log out, and log back in?

I have to set solo layout to none for the error to be relevant but yes.

Name Size MD5
Grid.lua 9.8 KiB fe4d3c1c0cdf...
User When Change
Phanx Jul 08, 2013 at 22:26 UTC Changed name from Grid not appearing during combat to Grid not appearing during combat when layout was None
Phanx Jul 08, 2013 at 22:24 UTC
Phanx Jun 19, 2013 at 19:55 UTC Changed description type from Plain Text to Markdown

Changed description:
  #### **Grid version:**
- *Check the addon’s TOC file if you’re not sure!*

  5.2.0.1600
-
  #### **WoW version and region/language:**
- *Check the WoW login screen if you’re not sure!*
  5.3 enGB
-
  #### **Steps to reproduce the problem:**
----------------------------------------
  Grid appearing.

-
  #### **What actually happened:**

  Nothing. (including no errors)
-

  #### **Does the problem still happen when all other addons — including all Grid plugins — are disabled?**
  Yes.

-
  #### **Does the problem still happen after you switch to a new profile in Grid with default settings, log out, and log back in?**
- *If not, please attach your Grid saved variables file to your ticket, and TELL US WHICH PROFILE you were using when the problem happened.*
  I have to set solo layout to none for the error to be relevant but yes.
Lombra Jun 19, 2013 at 14:38 UTC

Added attachment Grid.lua

Lombra Jun 19, 2013 at 14:35 UTC Create

You must login to post a comment. Don't have an account? Register to get one!

  • 1 comment
  • Avatar of Phanx Phanx Jul 08, 2013 at 22:24 UTC - 0 likes

    Note to self: problem is likely caused by GridLayout:UpdateVisibility() hiding the layout frame (to hide the visible backdrop) when the layout is set to None. Possible solution: create the visible backdrop separately so it can be freely hidden and shown.

    Last edited Jul 09, 2013 by Phanx
  • 1 comment

Facts

Last updated
Jul 08, 2013
Reported
Jun 19, 2013
Status
Accepted - Problem reproduced / Need acknowledged.
Type
Defect - A shortcoming, fault, or imperfection
Priority
Medium - Normal priority.
Votes
0

Reported by

Possible assignees