Grid

654 - spectator mode

Hi,

When actually raiding, grid works perfectly fine for me, but while not being inside the instance (idling around somewhere while others are wiping on boss xyz), grid would generally update health every ~3s and not show any bossrelated buffs and debuffs at all (standard buffs and debuffs such as forbearance or rallying cry would still show though)

I don't know if this is intended (to save ressources or something), but would it be possible to add the option to make grid work normally even if you are only "spectating"? I know that it must be possible, since blizz ui raidframe actually does it.

User When Change
Phanx Oct 22, 2012 at 01:45 UTC
savethetrees Oct 21, 2012 at 20:10 UTC Create

You must login to post a comment. Don't have an account? Register to get one!

  • 3 comments
  • Avatar of Phanx Phanx Oct 23, 2012 at 00:08 UTC - 0 likes

    Please post a new bug report following the ticket template, so that I have all the information I need in a useful format. In particular, the ticket template requests a copy of your saved variables so I can actually load your settings in-game for debugging. I ask for specific information in a specific format for a reason. I have a day job and a life outside of maintaining Grid (and 20+ other addons). I just don't have time to try to track down bugs that aren't submitted in the proper format and are missing half of the information I need to effectively locate the problem, sorry.

  • Avatar of savethetrees savethetrees Oct 22, 2012 at 22:47 UTC - 0 likes

    Hmmmm ok there is indeed rather something buggy.... I first thought it would be only when I am not inside the instance, but today I noticed that all my debuffs were not working even inside the instance. Deleting the debuffs and reentering them (I track buffs and debuffs manually, not using statusraiddebuffs) under status auras solved the problem though. Bug sack does not show any bugs and the problem still occurs with no other addons enabled, and I cleared my cache folder.

    I just tried some debuffs of older bosses, and none seem to work. Here's some screenshots http://www.imagebanana.com/view/42bt0xgl/WoWScrnShot_102312_002633.jpg http://www.imagebanana.com/view/pfxhwy5e/WoWScrnShot_102312_002652.jpg http://www.imagebanana.com/view/5uu85h0u/WoWScrnShot_102312_002824.jpg As you can see, I am tracking the debuff "ice patch" applied by that mob in throne of the 4 winds, when you are standing in the ice patch. Everything is set up correctly but no debuff in grid.

    The problem never occured before the last release update, and I didn't change anything in my UI recently, so could it be that something changed how grid would store the information, and that backwards compability with the information from back then is an issue? I really don't like the idea of completely redoing all settings .... so, do you have a clue what could be done?

    Last edited Oct 22, 2012 by savethetrees
  • Avatar of Phanx Phanx Oct 22, 2012 at 01:45 UTC - 0 likes

    Grid responds to the same events that the Blizzard frames respond to, and gets the same return values from the same API functions.

    There is no reason why Grid would only update health every 3 seconds, and no reason why Grid would show some buffs/debuffs but not others. Can you give a specific example of a buff or debuff that isn't being displayed?

    Both of these sound like bugs. Please try the troubleshooting steps outlined on the How to report a bug page, and then post a bug report if the problem persists.

  • 3 comments

Facts

Last updated
Oct 22, 2012
Reported
Oct 21, 2012
Status
Invalid - This was not a valid report.
Type
Enhancement - A change which is intended to better the project in some way
Priority
Medium - Normal priority.
Votes
0

Reported by

Possible assignees