Grid

556 - On profile switch, some Frame settings are not applied

*** IMPORTANT: If you are using an alpha version of Grid, please do not post here. Alpha zips are generated from the current development code, and are never guaranteed to work. Roll back to the latest release version if you're having a problem with an alpha version. ***

== What version of Grid are you using? (Tickets that do not include the actual version number will be ignored.)

4.1.0.1441

== What version and language of WoW are you using?

v 4.1.0 (14007)

== Does the problem still happen when you disable all addons (including Grid plugins) except for Grid?

Yes

== What is the problem? What were you doing when it happened? What steps can we follow to reproduce it?

When profiles have different frame size settings background frame doesn't re-size correctly when profiles are switched manually or via dual profile option. This causes unit frames to overlap. Can be fixed via UI reload (/reload).

== If there is an error message related to the problem, copy and paste it here:

None

== If the problem is graphical, take a screenshot and either attach it to your ticket, or upload it somewhere and include the URL here:

Please see attached screenshots.

== Please provide any additional information below.

Name Size MD5
Grid.lua 256.0 KiB c1cf41de04ed...
  • WoWScrnShot_051811_105220.jpeg
    Profile 1 - Normal
  • WoWScrnShot_051811_105248.jpeg
    Profile 1 - after spec switch
  • WoWScrnShot_051811_105236.jpeg
    Profile 2 - Normal
  • WoWScrnShot_051811_105310.jpeg
    Profile 2 - after spec switch
User When Change
Phanx Apr 22, 2012 at 01:52 UTC
Phanx Apr 14, 2012 at 03:33 UTC Changed name from Background frame not re-sizing when switching profiles to On profile switch, some Frame settings are not applied
Phanx Apr 02, 2012 at 13:16 UTC
Orego Jul 07, 2011 at 21:02 UTC
Orego Jul 07, 2011 at 21:00 UTC

Added attachment Grid.lua

Phanx Jul 07, 2011 at 10:38 UTC
Orego Jun 09, 2011 at 15:24 UTC

Deleted attachment Grid_Normal_After_ReloadUI.png: wrong

Orego Jun 09, 2011 at 15:24 UTC

Deleted attachment Grid_After_Spec_Switch.png: wrong

Orego Jun 09, 2011 at 15:23 UTC

Added attachment Grid_Normal_After_ReloadUI.png

Orego Jun 09, 2011 at 15:22 UTC

Added attachment Grid_After_Spec_Switch.png

Orego May 18, 2011 at 15:24 UTC

Added attachment WoWScrnShot_051811_105310.jpeg

Orego May 18, 2011 at 15:23 UTC

Added attachment WoWScrnShot_051811_105236.jpeg

Orego May 18, 2011 at 15:23 UTC

Added attachment WoWScrnShot_051811_105248.jpeg

Orego May 18, 2011 at 15:23 UTC

Added attachment WoWScrnShot_051811_105220.jpeg

Orego May 18, 2011 at 15:22 UTC Create

You must login to post a comment. Don't have an account? Register to get one!

  • 4 comments
  • Avatar of Phanx Phanx Apr 22, 2012 at 01:52 UTC - 0 likes

    Fixed in r1464. Get it from the Files tab on the project page, or wait for the next release.

  • Avatar of Phanx Phanx Apr 02, 2012 at 13:18 UTC - 0 likes

    I finally got around to testing this, and was able to reproduce the issue.

  • Avatar of Orego Orego Jul 07, 2011 at 21:02 UTC - 0 likes

    Attached....I use "Default" profile for healing and "DPS_2" profile for dps. Thanks.

  • Avatar of Phanx Phanx Jul 07, 2011 at 10:38 UTC - 0 likes

    Please attach your saved variables file for Grid, and specify which profile(s) should be used to reproduce the problem.

  • 4 comments

Facts

Last updated
Apr 22, 2012
Reported
May 18, 2011
Status
Fixed - Developer made requested changes. QA should verify.
Type
Defect - A shortcoming, fault, or imperfection
Priority
Medium - Normal priority.
Votes
0

Reported by

Possible assignees