Grid

411 - Bug in GridRange.lua

** VERSIONS OF GRID BELOW r1356 ARE NOT COMPATIBLE WITH WOW 4.0. UPDATE GRID BEFORE REPORTING ERRORS! **

What version of Grid are you using?
r1379

What version (and language) of WoW are you using?
enGB, 4.0.1

What were you doing when the problem occured?
Um, nothing. The error popped up when I still was on the loginscreen.

What happened? What did you expect to happen instead?
An error-free loading? :)

Do you have an error log of what happened?
Yes, here it is:

1x Grid-1.40000.r1379\GridRange.lua:79 attempt to call method 'SetSpellBookItem' (a nil value)
Grid-1.40000.r1379\GridRange.lua:97 in function <Grid\GridRange.lua:94
(tail call): ?:
<in C code>: ?
<string>:"safecall Dispatcher[1]":9: in function <[string "safecall Dispatcher[1]"]:5>
(tail call): ?:
AceAddon-3.0-5 (Ace3):539: in function <Ace3\AceAddon-3.0\AceAddon-3.0.lua:532
(tail call): ?:
(tail call): ?:
Grid-1.40000.r1379\GridCore.lua:266 in function `EnableModules'
Grid-1.40000.r1379\GridCore.lua:198 in function <Grid\GridCore.lua:195
(tail call): ?:
<in C code>: ?
<string>:"safecall Dispatcher[1]":9: in function <[string "safecall Dispatcher[1]"]:5>
(tail call): ?:
AceAddon-3.0-5 (Ace3):539: in function `EnableAddon'
AceAddon-3.0-5 (Ace3):629: in function <Ace3\AceAddon-3.0\AceAddon-3.0.lua:615
<in C code>: in function `LoadAddOn'
Interface\FrameXML\UIParent.lua:242 in function `UIParentLoadAddOn':
Interface\FrameXML\UIParent.lua:265 in function `CombatLog_LoadUI':
Interface\FrameXML\UIParent.lua:519 in function <Interface\FrameXML\UIParent.lua:492

  ---

Does the problem still happen when you disable all addons (including Grid plugins) except for Grid?
Honestly I didn't tried that. But since I get the error without actively using Grid, I doubt it'll help.

Please provide any additional information below.

Please check on your ticket daily. If a ticket is waiting on a response from you for more than 7 days, I will assume that you have fixed the problem yourself and have abandoned the ticket.

User When Change
Phanx Oct 21, 2010 at 17:36 UTC Changed status from New to Invalid
Ydrisselle Oct 20, 2010 at 23:34 UTC Create

You must login to post a comment. Don't have an account? Register to get one!

  • 2 comments
  • Avatar of Ydrisselle Ydrisselle Oct 21, 2010 at 12:45 UTC - 0 likes

    Yes, I'm using disembedded libraries.

    edit: and it seems I missed your update... I'll test it tonight.

    Last edited Oct 21, 2010 by Ydrisselle
  • Avatar of Greltok Greltok Oct 21, 2010 at 06:45 UTC - 0 likes

    Are you running LibGratuity-3.0 disembedded?

  • 2 comments

Facts

Last updated
Oct 21, 2010
Reported
Oct 20, 2010
Status
Invalid - This was not a valid report.
Type
Defect - A shortcoming, fault, or imperfection
Priority
Medium - Normal priority.
Votes
0

Reported by

Possible assignees