Grid

278 - frame lockups

What version of Grid are you using?
r1278 currently, but tried alot of versions

What version (and language) of WoW are you using?
3.3 en

What were you doing when the problem occured?
anything

What happened?  What did you expect to happen instead?
It was a ticket about frame locks before but was closed because you couldnt reproduce it. It happens on every group change (someone is changing zone, joining or leaving group). It's very hard to play in large groups (IoC, AV), even in 25 man raids it is annoying.

Do you have an error log of what happened?
no

Please provide any additional information below.
The reason i'm posting this ticked again is that i found something new. It happens only when i use an opengl engine (wow.exe -opengl). May be the grid is using something to update the frame which is buggy in opengl implementation. Although Grid2 is not affected, it's working smooth, but not really usable for me.

Name Description Size MD5
small_patch.zip without logic changes 9.9 KiB ca9e90f34d4e...
User When Change
Phanx Oct 13, 2010 at 12:32 UTC Changed status from Accepted to Fixed
triamazikamno Oct 13, 2010 at 11:45 UTC

Deleted attachment grid_lockups_patch_v7b.zip: obsolete

triamazikamno Sep 29, 2010 at 10:10 UTC

Deleted attachment grid_lockups_patch_v7a.zip: obsolete

triamazikamno Sep 29, 2010 at 10:09 UTC

Deleted attachment grid_lockups_patch_v7.zip: broken

triamazikamno Sep 29, 2010 at 10:09 UTC

Deleted attachment grid_lockups_patch_v6.zip: broken

triamazikamno Sep 22, 2010 at 16:22 UTC

Added attachment small_patch.zip

triamazikamno Sep 20, 2010 at 03:19 UTC

Added attachment grid_lockups_patch_v7b.zip

triamazikamno Sep 17, 2010 at 22:02 UTC

Added attachment grid_lockups_patch_v7a.zip

triamazikamno Sep 16, 2010 at 10:43 UTC

Added attachment grid_lockups_patch_v7.zip

triamazikamno Sep 11, 2010 at 08:28 UTC

Deleted attachment grid_lockups_patch_v5.zip: broken

triamazikamno Sep 11, 2010 at 08:04 UTC

Added attachment grid_lockups_patch_v6.zip

triamazikamno Sep 11, 2010 at 08:04 UTC

Deleted attachment grip_lockups_patch_v6.zip: typo

triamazikamno Sep 11, 2010 at 08:03 UTC

Added attachment grip_lockups_patch_v6.zip

triamazikamno Sep 11, 2010 at 07:54 UTC

Deleted attachment grid_lockups_patch_v4.zip: broken

triamazikamno Sep 07, 2010 at 12:52 UTC

Deleted attachment grid_lockups_patch_v3.zip: broken

triamazikamno Sep 07, 2010 at 12:39 UTC

Added attachment grid_lockups_patch_v5.zip

triamazikamno Sep 07, 2010 at 04:38 UTC Changed description:
+ plain$What version of Grid are you using?
+ r1278 currently, but tried alot of versions
+
+ What version (and language) of WoW are you using?
+ 3.3 en
+
+ What were you doing when the problem occured?
+ anything
+
+ What happened?  What did you expect to happen instead?
+ It was a ticket about frame locks before but was closed because you couldnt reproduce it. It happens on every group change (someone is changing zone, joining or leaving group). It's very hard to play in large groups (IoC, AV), even in 25 man raids it is annoying.
+
+ Do you have an error log of what happened?
+ no
+
+ Please provide any additional information below.
+ The reason i'm posting this ticked again is that i found something new. It happens only when i use an opengl engine (wow.exe -opengl). May be the grid is using something to update the frame which is buggy in opengl implementation. Although Grid2 is not affected, it's working smooth, but not really usable for me.
triamazikamno Sep 07, 2010 at 04:38 UTC

Added attachment grid_lockups_patch_v4.zip

triamazikamno Sep 07, 2010 at 04:38 UTC

Deleted attachment grid_lockups_patch_v4.zip: typo

triamazikamno Sep 07, 2010 at 04:25 UTC

Added attachment grid_lockups_patch_v4.zip

triamazikamno Sep 06, 2010 at 17:58 UTC

Added attachment grid_lockups_patch_v3.zip

triamazikamno Sep 06, 2010 at 17:58 UTC

Deleted attachment grid_lockups_patch_v2.zip: broken

triamazikamno Sep 06, 2010 at 17:57 UTC

Deleted attachment grid_lockups_patch.zip: broken

triamazikamno Sep 05, 2010 at 08:01 UTC

Added attachment grid_lockups_patch_v2.zip

triamazikamno Sep 05, 2010 at 08:01 UTC

Deleted attachment grip_lockups_patch_v2.zip: typo

triamazikamno Sep 05, 2010 at 07:59 UTC

Added attachment grip_lockups_patch_v2.zip

Phanx Sep 01, 2010 at 04:47 UTC Changed status from Replied to Accepted
triamazikamno Aug 23, 2010 at 16:17 UTC

Added attachment grid_lockups_patch.zip

FallenLegionEU Aug 09, 2010 at 18:27 UTC Changed status from Waiting to Replied
Phanx Aug 08, 2010 at 23:14 UTC Changed status from Replied to Waiting
triamazikamno Feb 06, 2010 at 00:02 UTC Changed status from Waiting to Replied
Phanx Feb 05, 2010 at 23:10 UTC Changed status from Replied to Waiting
triamazikamno Feb 05, 2010 at 00:41 UTC Changed status from Waiting to Replied
Phanx Feb 05, 2010 at 00:11 UTC Changed status from Replied to Waiting
triamazikamno Feb 03, 2010 at 07:35 UTC Changed status from Waiting to Replied
Phanx Feb 02, 2010 at 23:40 UTC Changed assigned to from Pastamancer to Phanx
Phanx Feb 02, 2010 at 23:40 UTC Changed status from New to Waiting
triamazikamno Jan 30, 2010 at 20:30 UTC Create

You must login to post a comment. Don't have an account? Register to get one!

  • Avatar of triamazikamno triamazikamno Feb 03, 2010 at 08:17 UTC - 0 likes
  • Avatar of triamazikamno triamazikamno Feb 03, 2010 at 07:35 UTC - 0 likes

    1. Client freezes up for several frames
    2. Yes
    3. Yes
    4. Think i tried it, but not sure. Will check as soon as servers go up after maintenance.
    Will post info from debug later aswell

    Last edited Feb 03, 2010 by triamazikamno
  • Avatar of Phanx Phanx Feb 02, 2010 at 23:40 UTC - 0 likes

    I can't find your other ticket at all now, but I don't remember marking it as Invalid. In fact, I'm pretty sure I'd replied asking for more information, as I was unable to reproduce it.

    1. What exactly do you mean by "frame lock"? Does the client freeze up for several frames? Does the client completely crash? Does Grid simply fail to update its frames?

    2. Does the problem occur when all addons except for the Grid core addon are disabled?

    3. Does the problem occur when using Grid's default settings (remove the saved variables file, or switch to a new profile and reload the UI)?

    4. Does the problem occur if you have all statuses disabled (Grid > Status > [status] > uncheck Enable)?

    Another thing you could try would be to enable debugging for all Grid modules (Grid > Debug > check everything) and watch carefully what happens when your group changes. The last messages printed to the chat frame should give some clue as to where the problem is happening. Do this with all other addons disabled, including external Grid plugins.

Facts

Last updated
Mar 30, 2012
Reported
Jan 30, 2010
Status
Fixed - Developer made requested changes. QA should verify.
Type
Defect - A shortcoming, fault, or imperfection
Priority
Medium - Normal priority.
Votes
5

Reported by

Possible assignees