GnomeWorks TradeSkill Frame

430 - r186 Couldnt even open profesion window

When i tried to use lastest version i couldnt even open profesion window

Date: 2012-09-14 22:12:42
ID: -2
Error occured in: Global
Count: 2
Message: ...erface\AddOns\GnomeWorks\Libs\LibStagedExecution.lua line 22:
   script ran too long
Debug:
   ...erface\AddOns\GnomeWorks\Libs\LibStagedExecution.lua:22
      ...erface\AddOns\GnomeWorks\Libs\LibStagedExecution.lua:13
Locals:
frame = <unnamed> {
 0 = <userdata>
 list = <table> {
 }
}
elapsed = 0.02000000141561
list = <table> {
 segments = <table> {
 }
 AddSegment = <function> defined @Interface\AddOns\GnomeWorks\Libs\LibStagedExecution.lua:54
 frame = <unnamed> {
 }
 delay = -0.02000000141561
 Execute = <function> defined @Interface\AddOns\GnomeWorks\Libs\LibStagedExecution.lua:65
}
entry = <table> {
 name = "GnomeWorks: InitializeData"
 retry = 0
 func = <function> defined @Interface\AddOns\GnomeWorks\GnomeWorks.lua:598
}
(*temporary) = false
(*temporary) = "Interface\AddOns\GnomeWorks\SkillList.lua:161 script ran too long"
(*temporary) = "Interface\AddOns\GnomeWorks\SkillList.lua:161 script ran too long"
(*temporary) = false
(*temporary) = "  my char name"
(*temporary) = "my server"
(*temporary) = "script ran too long"

User When Change
WildCard_25 Oct 16, 2012 at 08:13 UTC
Radoznali Sep 14, 2012 at 20:24 UTC Create

You must login to post a comment. Don't have an account? Register to get one!

  • 3 comments
  • Avatar of WildCard_25 WildCard_25 Sep 19, 2012 at 11:38 UTC - 0 likes

    You tried to open GnomeWorks while in combat (the only time that the new 'script ran too long' error can occur). This is a new limitation introduced with patch 5.05 that is causing quite a few addons to fail if they are activated while in combat (including BugGrabber :-) )

    I'm hoping to get some time to look at a work-around for this error on the weekend.

  • Avatar of Gwizzz Gwizzz Sep 16, 2012 at 23:50 UTC - 0 likes

    Or.. the existing libraries in Gnomeworks\lib are out of date. Either way, if installing the entire ace3 library from Curse resolves your errors that would be good to know.

  • Avatar of Gwizzz Gwizzz Sep 16, 2012 at 23:44 UTC - 0 likes

    I downloaded r186 and it worked fine.

    Check to see if you have the Ace3 libraries installed as they are supposed to be embedded into, and are a dependency, of Gnomeworks. There are two Ace libraries in Gnomeworks\Lib folder but about a dozen or more exist.

    I emailed a friend a copy of GW and he was also getting errors, not sure if they are the same as yours, until he downloaded and installed the complete Ace3 library folder. I can only guess there is another function GW is looking for that is not included in the two libraries it already has, but is being loaded by one of the other dozen mods I have installed. I haven't needed to install the full Ace3 set of libraries to have GW work for me.

    Here is a link to the latest version of the Ace3 libraries on Curse. Let us know if installing these fixes your problem. That will confirm that more than the existing two Ace3 libraries should be listed as a dependency. http://www.curse.com/addons/wow/ace3

  • 3 comments

Facts

Last updated
Oct 16, 2012
Reported
Sep 14, 2012
Status
Accepted - Problem reproduced / Need acknowledged.
Type
Defect - A shortcoming, fault, or imperfection
Priority
Medium - Normal priority.
Votes
0

Reported by

Possible assignees