FlightHUD

25 - attempt to index field 'waypoint' (a nil value) Quest Helper<>FlightHUD Error in Global

What steps will reproduce the problem?
1. Take a mage and teleport to Dalran city (havent
2. use your hearthstone to go home
3. Take a Portal to a town from either a mage, of from dalaran/shattrath portals

What is the expected output? What do you see instead?
I exspect no real change in behavior than normal operation. i see an error and Flighthud no longer point to my next objective.
FlightHUD still is visible on screen
quest helper also throws an error, but does not break itself, least  form what i see.

What version of the product are you using?
0.9.14

Do you have an error log of what happened?
Date: 2010-04-19 04:12:42
ID: 1
Error occured in: Global
Count: 1
Message: ..\AddOns\FlightHUD\FlightHUD.lua line 1633:
   attempt to index field 'waypoint' (a nil value)
Debug:
   (tail call): ?
   [C]: ?
   FlightHUD\FlightHUD.lua:1633 AddTWaypoint()
   FlightHUD\FlightHUD.lua:1627 func()
   QuestHelper\dodads.lua:950 InvokeWaypointCallbacks()
   QuestHelper\dodads.lua:1042
      QuestHelper\dodads.lua:1015
   QuestHelper\manager_event.lua:157 func()
   QuestHelper\manager_event.lua:43
      QuestHelper\manager_event.lua:25
   QuestHelper\manager_event.lua:111
      QuestHelper\manager_event.lua:99
AddOns:
  FlightHUD, v0.9.14
  QuestHelper, v1.3.11

Please provide any additional information below.
i seen this error last version aswell. but didnt think to post an error of it untill the last update broke fligth hud becuse i thought it was an abandoned project. i appreciate your contenued work on this addon, as it is a nice addition to my interface.

This is the /qh error Message
msg: Too many stored objectives (24510 0 1)
toc: 1.3.11
v: 1.3.11
game: 3.3.3
locale: enUS
timestamp: 2010-04-19 04:11:13
mutation: nil
silent: true

Interface\AddOns\QuestHelper\director_quest.lua:734 in function `QH_UpdateQuests'
Interface\AddOns\QuestHelper\db_get.lua:112 in function `DB_Init'
Interface\AddOns\QuestHelper\main.lua:458 in function <Interface\AddOns\QuestHelper\main.lua:406

addons:

---- Following loud error

msg: Interface\AddOns\FlightHUD\FlightHUD.lua:1633 attempt to index field 'waypoint' (a nil value)
toc: 1.3.11
v: 1.3.11
game: 3.3.3
locale: enUS
timestamp: 2010-04-19 04:12:43
mutation: nil
silent: false

(Coroutine error in new_routing)

User When Change
Barfolomeu Apr 22, 2010 at 20:05 UTC Changed status from Replied to Duplicate
Barfolomeu Apr 22, 2010 at 20:04 UTC Changed status from Waiting to Replied
Barfolomeu Apr 20, 2010 at 03:04 UTC Changed status from New to Waiting
AU518987077 Apr 19, 2010 at 10:22 UTC

Added attachment wow-20100419-041717.bmp

AU518987077 Apr 19, 2010 at 10:22 UTC Create

You must login to post a comment. Don't have an account? Register to get one!

  • 1 comment
  • Avatar of Barfolomeu Barfolomeu Apr 22, 2010 at 20:04 UTC - 0 likes

    27 is a duplicate of this one, but since there are comments in 27, I'm making this the dupe.

  • 1 comment

Facts

Last updated
Apr 22, 2010
Reported
Apr 19, 2010
Status
Duplicate - This report duplicates an existing ticket.
Type
Defect - A shortcoming, fault, or imperfection
Priority
Medium - Normal priority.
Votes
0

Reported by

Possible assignees