Elkano's BuffBars

89 - Multiple Ace2 related(?) errors

May be related to Ticket #62.

I receive multiple errors on load that do not occur with EBB disabled. I have Ace3 installed and active, but not Ace2. Is Ace2 still required? Because that throws entirely different wobblies. Using EBB r160 (alpha), though the same errors throw with R150 (2.2.5 release). If I disable DewdropLib, or TabletLib, the errors are different (to the effect of "EBB requires Dewdrop", &c.)

Here are the errors I get on load without Ace2 installed. I've lopped off the addons list:

1:
Message: ...erface\AddOns\DewdropLib\Dewdrop-2.0\Dewdrop-2.0.lua line 16:
Dewdrop-2.0 requires AceLibrary
Debug:
[C]: ?
[C]: error()
...erface\AddOns\DewdropLib\Dewdrop-2.0\Dewdrop-2.0.lua:16: in main chunk

2
Message: ..\AddOns\TabletLib\Tablet-2.0\Tablet-2.0.lua line 16:
Tablet-2.0 requires AceLibrary
Debug:
[C]: ?
[C]: error()
TabletLib\Tablet-2.0\Tablet-2.0.lua:16: in main chunk

3
Message: ...\FuBarPlugin-2.0\FuBarPlugin-2.0\FuBarPlugin-2.0.lua line 23:
FuBarPlugin-2.0 requires AceOO-2.0.
Debug:
[C]: ?
[C]: error()
...\FuBarPlugin-2.0\FuBarPlugin-2.0\FuBarPlugin-2.0.lua:23: in main chunk

4 - Re: this error, Dewdrop2.0 is installed and active, but since it requires AceLibrary, EBB doesn't see it?
Message: ..\AddOns\ElkBuffBars\ElkBuffBars.lua line 3:
Cannot find a library instance of Dewdrop-2.0.
Debug:
[C]: ?
[C]: error()
...AddOns\Broker_Location\lib\AceLibrary\AceLibrary.lua:490: AceLibrary()
ElkBuffBars\ElkBuffBars.lua:3: in main chunk

5
Message: ..\AddOns\ElkBuffBars\EBB_Bar.lua line 2:
attempt to index global 'ElkBuffBars' (a nil value)
Debug:
[C]: ?
ElkBuffBars\EBB_Bar.lua:2: in main chunk

6
Message: ..\AddOns\ElkBuffBars\EBB_BarGroup.lua line 2:
attempt to index global 'ElkBuffBars' (a nil value)
Debug:
[C]: ?
ElkBuffBars\EBB_BarGroup.lua:2: in main chunk

7
Message: ...face\AddOns\ElkBuffBars\locales\ElkBuffBars.enUS.lua line 2:
attempt to index global 'ElkBuffBars' (a nil value)
Debug:
[C]: ?
...face\AddOns\ElkBuffBars\locales\ElkBuffBars.enUS.lua:2: in main chunk

8-12 - Errors 8-12 are identical except they refer to different localization files. deDE is representative.
Message: ...face\AddOns\ElkBuffBars\locales\ElkBuffBars.deDE.lua line 2:
attempt to index global 'ElkBuffBars' (a nil value)
Debug:
[C]: ?
...face\AddOns\ElkBuffBars\locales\ElkBuffBars.deDE.lua:2: in main chunk

User When Change
Tourbillon Nov 15, 2010 at 00:28 UTC Create

You must login to post a comment. Don't have an account? Register to get one!

  • 2 comments
  • Avatar of Fragglerock Fragglerock Jan 02, 2011 at 14:59 UTC - 0 likes

    same here, having issues with Ace2....

  • Avatar of Kerecha Kerecha Nov 18, 2010 at 10:50 UTC - 0 likes

    EBB is still an Ace2 addon so it needs Ace2 active.

    Im guessing thou im not the only one looking forward to it getting moved to Ace3 completely

  • 2 comments

Facts

Reported
Nov 15, 2010
Status
New - Issue has not had initial review yet.
Type
Defect - A shortcoming, fault, or imperfection
Priority
Medium - Normal priority.
Votes
0

Reported by

Possible assignees