DrDamage

290 - DrDamage doesn't work at all.

I don't get any numbers on my Action-bars or anything on my tooltips.
I can open the configuration window tho.

Lua Error

Message: Interface\AddOns\DrDamage\DrDamage.lua:2221: attempt to call upvalue 'GetNumTalentTabs' (a nil value)
Time: 07/13/13 18:20:49
Count: 1
Stack:
Interface\AddOns\DrDamage\DrDamage.lua:2221: in function GeneralOptions' Interface\AddOns\DrDamage\DrDamage.lua:589: in function?'
Interface\AddOns\Ace3\AceTimer-3.0\AceTimer-3.0.lua:41: in function <Interface\AddOns\Ace3\AceTimer-3.0\AceTimer-3.0.lua:36>

Locals:
self = {
defaults =

{
}
modules =
{
}
CancelTimer = <function> defined @Interface\AddOns\Ace3\AceTimer-3.0\AceTimer-3.0.lua:161
SecureHook = <function> defined @Interface\AddOns\Ace3\AceHook-3.0\AceHook-3.0.lua:339
Caster_OnEnable = <function> defined @Interface\AddOns\DrDamage\Caster.lua:62
GeneralOptions = <function> defined @Interface\AddOns\DrDamage\DrDamage.lua:910
UNIT_COMBO_POINTS = <function> defined @Interface\AddOns\DrDamage\DrDamage.lua:2366
GetWeaponBuff = <function> defined @Interface\AddOns\DrDamage\DrDamage.lua:3264
IsEnabled = <function> defined @Interface\AddOns\Ace3\AceAddon-3.0\AceAddon-3.0.lua:482
ScheduleTimer = <function> defined @Interface\AddOns\Ace3\AceTimer-3.0\AceTimer-3.0.lua:108
SaveTooltip = <function> defined @Interface\AddOns\DrDamage\DrDamage.lua:2831
UNIT_POWER = <function> defined @Interface\AddOns\DrDamage\DrDamage.lua:2298
RegisterMessage = <function> defined @Interface\AddOns\Ace3\CallbackHandler-1.0\CallbackHandler-1.0.lua:118
UnregisterMessage = <function> defined @Interface\AddOns\Ace3\CallbackHandler-1.0\CallbackHandler-1.0.lua:181
UpdateGlyphs = <function> defined @Interface\AddOns\DrDamage\DrDamage.lua:2784
hooks =
{
}
BuffCalc = <function> defined @Interface\AddOns\DrDamage\DrDamage.lua:3338
TargetHealth =
{
}
SetEnabledState = <function> defined @Interface\AddOns\Ace3\AceAddon-3.0\AceAddon-3.0.lua:455
Caster_CheckBaseStats = <function> defined @Interface\AddOns\DrDamage\Caster.lua:105
GetSpellHit = <function> defined @Interface\AddOns\DrDamage\DrDamage.lua:3247
ModifierUpdate = <function> defined @Interface\AddOns\DrDamage\DrDamage.lua:2658
ClearTooltip = <function> defined @Interface\AddOns\DrDamage\DrDamage.lua:2799
OnEnable = <function> defined @Interface\AddOns\DrDamage\DrDamage.lua:553
PET_BAR_HIDEGRID = <function> defined @Interface\AddOns\DrDamage\DrDamage.lua:2354
CasterCalc = <function> defined @Interface\AddOns\DrDamage\Caster.lua:179
OnInitialize = <function> defined @Interface\AddOns\DrDamage\DrDamage.lua:534
NewModule = <function> defined @Interface\AddOns\Ace3\AceAddon-3.0\AceAddon-3.0.lua:266
Calc = <function> defined @Interface\AddOns\DrDamage\DrDamage.lua:3289
ACTIONBAR_PAGE_CHANGED = <function> defined @Interface\AddOns\DrDamage\DrDamage.lua:2358
SetShapeshift = <function> defined @Interface\AddOns\DrDamage\DrDamage.lua:2862
GetLevels = <function> defined @Interface\AddOns\DrDamage\DrDamage.lua:3226
GetName = <function> defined @Interface\AddOns\Ace3\AceAddon-3.0\AceAddon-3.0.lua:310
name = "DrDamage"
Disable = <function> defined @Interface\AddOns\Ace3\AceAddon-3.0\AceAddon-3.0.lua:345
GetAP = <function> defined @Interface\AddOns\DrDamage\DrDamage.lua:3199
Unhook = <function> defined @Interface\AddOns\Ace3\AceHook-3.0\AceHook-3.0.lua:421
Print = <function> defined @Interface\AddOns\Ace3\AceConsole-3.0\AceConsole-3.0.lua:54
MatchData = <function> defined @Interface\AddOns\DrDamage\DrDamage.lua:108
LoadData = <function> defined @Interface\AddOns\DrDamage\DrDamage.lua:3443
Round = <function> defined @Interface\AddOns\DrDamage\DrDamage.lua:104
GetMeleeHit = <function> defined @Interface\AddOns\DrDamage\DrDamage.lua:3256
GetRating = <function> defined @Interface\AddOns\DrDamage\DrDamage.lua:3176
UnregisterEvent = <function> defined @Interface\AddOns\Ace3\CallbackHandler-1.0\CallbackHandler-1.0.lua:181
GetSetAmount = <function> defined @Interface\AddOns\DrDamage\DrDamage.lua:2746
SetDefaultModuleLibraries = <function> defined @Interface\AddOns\Ace3\AceAddon-3.0\AceAddon-

User When Change
angosia Sep 06, 2013 at 02:33 UTC
Pokiaka Jul 13, 2013 at 15:27 UTC Create

You must login to post a comment. Don't have an account? Register to get one!

  • 1 comment
  • Avatar of angosia angosia Sep 06, 2013 at 02:33 UTC - 0 likes

    This error is caused by using an invalid version of the mod. I am closing the ticket and declining to work on it. Please see the FAQ.

  • 1 comment

Facts

Last updated
Sep 06, 2013
Reported
Jul 13, 2013
Status
Invalid - This was not a valid report.
Type
Defect - A shortcoming, fault, or imperfection
Priority
Medium - Normal priority.
Votes
0

Reported by

Possible assignees