CowTip

22 - invalid fontHeight

What steps will reproduce the problem?

  1. Buy dual spec from trainer
  2. Activate the second spec

What is the expected output? What do you see instead?

Expect no error. Error pops out

What version of the product are you using?

1.3

Do you have an error log of what happened?

[2009/04/16 16:23:51-771-x1]: CowTip-r68121\Appearance\Appearance.lua:426: ERROR: <unnamed>:SetFont(): invalid fontHeight: 0, height must be > 0
CowTip-r68121\Appearance\Appearance.lua:426: in function `SetFont'
CowTip-r68121\Appearance\Appearance.lua:302: in function <Interface\AddOns\CowTip\Appearance\Appearance.lua:297>
<in C code>: in function `SetUnit'
...ns\LibDogTag-Unit-3.0\Categories\TooltipScanning.lua:36: in function <...ns\LibDogTag-Unit-3.0\Categories\TooltipScanning.lua:26>:
...ns\LibDogTag-Unit-3.0\Categories\TooltipScanning.lua:44: in function <...ns\LibDogTag-Unit-3.0\Categories\TooltipScanning.lua:43>:
(tail call): ?:
<string>:"local _G = _G;...":29: in function <[string "local _G = _G;..."]:10>
(tail call): ?:
<in C code>: in function `xpcall'
LibDogTag-3.0-90203\Compiler.lua:2188: in function <Interface\AddOns\LibDogTag-3.0\Compiler.lua:2175>
(tail call): ?:
CowTip-r68121\Text\Text.lua:288: in function `RefixLines'
CowTip-r68121\Text\Text.lua:371: in function <Interface\AddOns\CowTip\Text\Text.lua:344>
<in C code>: ?
LibRockModuleCore-1.0-90234 (LibRockModuleCore-1.0):398: in function `CallMethodOnAllModules'
CowTip-r68121\CowTip.lua:239: in function <Interface\AddOns\CowTip\CowTip.lua:229>
CowTip-r68121\CowTip.lua:253: in function <Interface\AddOns\CowTip\CowTip.lua:246>
(tail call): ?:

Please provide any additional information below.

Tooltips appear to be still functioning

User When Change
rainrider Apr 16, 2009 at 14:37 UTC Create

You must login to post a comment. Don't have an account? Register to get one!

  • 5 comments
  • Avatar of Garkin Garkin May 22, 2009 at 21:07 UTC - 0 likes

    got the same error:

    [2009/05/22 21:52:34-28-x1]: CowTip-r68121\Appearance\Appearance.lua:431: ERROR: <unnamed>:SetFont(): invalid fontHeight: -1.#QNAN, height must be > 0
    CowTip-r68121\Appearance\Appearance.lua:431: in function `SetFont'
    CowTip-r68121\Appearance\Appearance.lua:304: in function <Interface\AddOns\CowTip\Appearance\Appearance.lua:299>
    <in C code>: in function `SetHyperlink'
    LibStatLogic-1.1-49:12330: in function `GetSum'
    RatingBuster-1.4.4 (r$Revision: 226 $)\RatingBuster.lua:4006: in function `StatSummary'
    RatingBuster-1.4.4 (r$Revision: 226 $)\RatingBuster.lua:2388: in function `handler'
    LibTipHooker-1.1-2:193: in function <...ingBuster\libs\LibTipHooker-1.1\LibTipHooker-1.1.lua:187>
    <in C code>: in function `SetQuestItem'
    <string>:"*:OnEnter":4: in function <[string "*:OnEnter"]:1>
    
      ---
    

    It seems that this error occurs just once and then everything works correctly.

  • Avatar of Venara Venara May 15, 2009 at 17:10 UTC - 0 likes

    Still getting this error with 1.3.1: http://epochenkampf.lima-city.de/dreamroot/pictures/cowtiperror.jpg

    As virginc said, pops up only once when i heal someone or myself. It won't show up again until i login again / reloadui / etc.

  • Avatar of networkerror networkerror Apr 17, 2009 at 02:48 UTC - 0 likes

    Alpha r45 appears to have fixed the issue

  • Avatar of rainrider rainrider Apr 16, 2009 at 18:46 UTC - 0 likes

    Some more of the same:

    2009/04/16 20:17:33-773-x2]: CowTip-r68121\Appearance\Appearance.lua:426: ERROR: <unnamed>:SetFont(): invalid fontHeight: 0, height must be > 0
    CowTip-r68121\Appearance\Appearance.lua:426: in function `SetFont'
    CowTip-r68121\Appearance\Appearance.lua:302: in function <Interface\AddOns\CowTip\Appearance\Appearance.lua:297>
    <in C code>: ?
    <in C code>: in function `SetHyperlinkCompareItem'
    Interface\FrameXML\GameTooltip.lua:285: in function `GameTooltip_ShowCompareItem':
    <string>:"*:OnTooltipSetItem":3: in function <[string "*:OnTooltipSetItem"]:1>
    <in C code>: ?
    <in C code>: ?
    AceHook-3.0-5 (Ace3):92: in function `OnTooltipSetItem'
    CowTip-r68121\CowTip.lua:259: in function <Interface\AddOns\CowTip\CowTip.lua:257>
    (tail call): ?:
    <in C code>: ?
    <in C code>: ?
    <in C code>: in function `SetInventoryItem'
    RepairBroker-3.0.9 Beta2\RepairBroker.lua:171: in function <Interface\AddOns\RepairBroker\RepairBroker.lua:154>
    
      ---
    
    [2009/04/16 20:15:10-773-x1]: CowTip-r68121\Appearance\Appearance.lua:426: ERROR: <unnamed>:SetFont(): invalid fontHeight: 0, height must be > 0
    CowTip-r68121\Appearance\Appearance.lua:426: in function `SetFont'
    CowTip-r68121\Appearance\Appearance.lua:302: in function <Interface\AddOns\CowTip\Appearance\Appearance.lua:297>
    <in C code>: in function `SetHyperlink'
    LibStatLogic-1.1-49:12072: in function `BuildGemmedTooltip'
    LibStatLogic-1.1-49:12932: in function `GetDiffID'
    RatingBuster-1.4.4 (r$Revision: 226 $)\RatingBuster.lua:2253: in function `handler'
    LibTipHooker-1.1-2:193: in function <...bTipHooker-1.1\LibTipHooker-1.1\LibTipHooker-1.1.lua:187>
    <in C code>: in function `SetInventoryItem'
    RepairBroker-3.0.9 Beta2\RepairBroker.lua:171: in function <Interface\AddOns\RepairBroker\RepairBroker.lua:154>
    
      ---
    

    This seems to be also related to this ticket.

  • Avatar of virginc virginc Apr 16, 2009 at 17:30 UTC - 0 likes

    I get that error after I log in and cast a heal on myself. After that it does not pop up anymore.

  • 5 comments

Facts

Last updated
Mar 30, 2012
Reported
Apr 16, 2009
Status
New - Issue has not had initial review yet.
Type
Defect - A shortcoming, fault, or imperfection
Priority
Medium - Normal priority.
Votes
3

Reported by

Possible assignees