Character Notes

6 - Character note not show in tooltip when MyRolePlay is installed

Zwixx on Curse says that the character note is not shown in tooltips when the MyRolePlay addon is intalled.

It isn't clear which addon is responsible for this issue.

User When Change
talryn1 Dec 29, 2013 at 19:54 UTC Changed status from New to Invalid
talryn1 Dec 02, 2011 at 21:23 UTC Create

You must login to post a comment. Don't have an account? Register to get one!

  • 4 comments
  • Avatar of talryn1 talryn1 Dec 29, 2013 at 19:54 UTC - 0 likes

    I was never able to find any other issues so I'm closing this ticket.

  • Avatar of talryn1 talryn1 Jan 09, 2012 at 18:52 UTC - 0 likes

    I'm glad you were able to fix it. It's unfortunate it took so much work.

  • Avatar of Zwixx Zwixx Jan 09, 2012 at 17:31 UTC - 0 likes

    @talryn1: Go

    I found a solution for me. I use StarTip who don't overwrite the Charakter Notes in the Tooltip, deactivate the tooltip in MyRolePlay completely. To see it in the tooltip I added

    if (UnitIsPlayer(unit) == nil) then
    return nil
    end
    local playername = UnitName(unit)
    _G.msp.Request(playername, "VA");
    if (_G.msp.char[playername] = nil) then
    if (_G.msp.char[playername].field["VA"] = "") then
    return _G.msp.char[playername].field["VA"]
    end
    end
    return nil

    to see the MRP-Status in the unit tooltip... A great solution for me :)

    Last edited Jan 09, 2012 by Zwixx
  • Avatar of talryn1 talryn1 Dec 02, 2011 at 21:28 UTC - 0 likes

    Quickly scanning the MyRolePlay code, I believe the issue is with that addon. It appears to overwrite tooltip lines. It's possible it is overwriting my addon's tooltip.

    I haven't experienced any negative interaction with other addons that add to the tooltip.

  • 4 comments

Facts

Last updated
Dec 29, 2013
Reported
Dec 02, 2011
Status
Invalid - This was not a valid report.
Type
Defect - A shortcoming, fault, or imperfection
Priority
Medium - Normal priority.
Votes
0

Reported by

Possible assignees