Bulk Mail Inbox

19 - Take Selected doesn't take all selected items

What steps will reproduce the problem?
1. Select 2 items from the Bulk Mail Inbox list
2. Click the Take Selected button at the bottom
3. Only one of the items will be taken, the other will remain in your inbox

What is the expected output? What do you see instead?
I'd expect all selected items to be taken.  This seems to have cropped up since the pre-cata patch.

What version of the product are you using?
4.0.5

Do you have an error log of what happened?
Where would I find this - it didn't pop an error message.  Nothing appears in Swatter.

Please provide any additional information below.
This doesn't seem to be specific to any type of mail or item. It happens with mail with individual items, such as from the auction house, as well as mail with multiple attachments.  It happens with mats, equipment, etc.  I'm not detecting an obvious pattern.

User When Change
Oddible Dec 31, 2010 at 18:54 UTC Create

You must login to post a comment. Don't have an account? Register to get one!

  • 2 comments
  • Avatar of dhedbor dhedbor Apr 27, 2011 at 06:07 UTC - 0 likes

    Hmm. I'll see if I can figure this one out.

  • Avatar of Oddible Oddible Jan 18, 2011 at 18:58 UTC - 0 likes

    I think I know what may be causing this. When I take a single item, the list gets re-ordered. When I take several items, it also gets re-ordered but I only get about half of my items - I'm wondering if there is some sort of checking whether the item ID at a location in the list matches the description of the item at that ID in the original selection list and if it doesn't match then it doesn't take the item. Not sure why the re-ordering is happening but I suspect this to be the culprit.

  • 2 comments

Facts

Last updated
Mar 30, 2012
Reported
Dec 31, 2010
Status
New - Issue has not had initial review yet.
Type
Defect - A shortcoming, fault, or imperfection
Priority
Medium - Normal priority.
Votes
2

Reported by

Possible assignees