!BugGrabber

50 - Localization phrases not synced with addon code

What steps will reproduce the problem?
1. Produce that many errors that the warning with the localization entry BUGGRABBER_STOPPED is shown.
2. It shows a text that contains two "%d" which are not replaced by values (deDE client).

What is the expected output? What do you see instead?
It should show a correct translation of the current english text (which doesn't use "%d").

What version of the product are you using?
r188

Do you have an error log of what happened?
-

Please provide any additional information below.
Seems like someone changed the english text (removed the "%d") but didn't update the localization phrases on WowAce. Please update the english texts of all phrases there and mark changed ones as "needs review" in all translations so that the translators can update the texts correctly.
In addition, some phrases are completely missing in the localization system and others can be deleted.

User When Change
funkydude Oct 21, 2013 at 13:51 UTC Changed status from New to Fixed
cremor Sep 15, 2012 at 16:59 UTC Changed description:
  Please provide any additional information below.
  Seems like someone changed the english text (removed the "%d") but didn't update the localization phrases on WowAce. Please update the english texts of all phrases there and mark changed ones as "needs review" in all translations so that the translators can update the texts correctly.
+ In addition, some phrases are completely missing in the localization system and others can be deleted.
cremor Aug 29, 2012 at 16:10 UTC Changed name from Values in BUGGRABBER_STOPPED localized string not replaced to Localization phrases not synced with addon code

Changed description:
  What steps will reproduce the problem?
- 1. Produce that many errors that the warning "BugGrabber has stopped capturing errors, since it has captured more than %d errors per second. Capturing will resume in %d seconds." is shown.
- 2. It shows %d instead of the values (both).
+ 1. Produce that many errors that the warning with the localization entry BUGGRABBER_STOPPED is shown.
+ 2. It shows a text that contains two "%d" which are not replaced by values (deDE client).
  What is the expected output? What do you see instead?
- It should replace the two %d with the real values.
+ It should show a correct translation of the current english text (which doesn't use "%d").

  What version of the product are you using?
  r188
----------------------------------------
  -

  Please provide any additional information below.
- I'm using a deDE client, so the actual message was the german one. But I can't see an error in the translation, the "%d"s are placed like in the english string, so it should work.
+ Seems like someone changed the english text (removed the "%d") but didn't update the localization phrases on WowAce. Please update the english texts of all phrases there and mark changed ones as "needs review" in all translations so that the translators can update the texts correctly.
cremor Aug 29, 2012 at 13:23 UTC Create

You must login to post a comment. Don't have an account? Register to get one!

  • 1 comment
  • Avatar of cremor cremor Sep 15, 2012 at 16:59 UTC - 0 likes

    I've now updated the german translations to match the english strings. But since this now looks wrong in the localization system, please still update the english strings there too.

    And of course I couldn't translate the missing phrases, so these need to be added.

  • 1 comment

Facts

Last updated
Oct 21, 2013
Reported
Aug 29, 2012
Status
Fixed - Developer made requested changes. QA should verify.
Type
Defect - A shortcoming, fault, or imperfection
Priority
Medium - Normal priority.
Votes
0

Reported by

Possible assignees