Bleeding Hearts

This project is abandoned.

Whether this project is out of date or its author marked it as abandoned, this project is no longer maintained.

If you wish to take this project over, please report it and state your intentions.

Examples

Monitors AP when dots are applied, clearly showing current vs applied AP levels. Ideal for Death Knights who want to know the best times to refresh those diseases with Pestilence. It will display correctly for Rogues and Druids, but it's rare these classes will want to refresh and use the energy in clipping their dots.

It can track all mobs at once, so switching targets doesn't matter.

The example picture here shows a couple of simple examples. The rupture has a number in the icon showing how many combos it was applied with, the rupture icon will only turn to red if you have at least this many currently and the AP is higher.

The Death Knight example on the right shows a good example of procs firing off after Icy Touch and before Plague Strike with over 600AP difference between the two.

Will add more description later, when I'm less tired.

TODO:

  • Spellpower mode for caster dots.
  • More skins for alternative display styles.

You must login to post a comment. Don't have an account? Register to get one!

  • 10 comments
  • Avatar of sindalee sindalee Apr 05, 2010 at 16:05 UTC - 0 likes

    update amg. march patch has made it wonky.

  • Avatar of psyquest psyquest Dec 13, 2009 at 13:28 UTC - 0 likes

    crashing with error: 2009/12/13 14:23:48-4575-x1]: ...ts\AceGUI-3.0-SharedMediaWidgets\SharedFunctions.lua:5: Cannot find a library instance of "LibSharedMedia-3.0".: !BugGrabber-2.2\libs\LibStub\LibStub.lua:23: in function `LibStub' ...ts\AceGUI-3.0-SharedMediaWidgets\SharedFunctions.lua:5: in main chunk:

    Cannot be used as is. Seems it has an issue with the lastest version of Pitbull.

  • Avatar of Barchetta Barchetta Oct 19, 2009 at 23:51 UTC - 0 likes

    Just updated and it's still not showing for me. It was fine till release 4, then it just stopped showing. If I back it up pre-4 it's fine.

  • Avatar of rashiakas rashiakas Oct 19, 2009 at 23:32 UTC - 0 likes

    Thanks a lot for this addon! Helps me with god specc a lot.

  • Avatar of Zeksie Zeksie Oct 19, 2009 at 18:19 UTC - 0 likes

    Thanks. Fixed packager for that now.

  • Avatar of Kukulkan Kukulkan Oct 18, 2009 at 04:00 UTC - 0 likes

    WIth 3.2.2 Release 5 getting the following error upon loging,

    [2009/10/17 21:58:40-339-x1]: BleedingHearts-1.0.$Revision: 11 $\BleedingHearts.lua:249: attempt to index global 'AceGUIWidgetLSMlists' (a nil value)

  • Avatar of Zeksie Zeksie Sep 28, 2009 at 11:39 UTC - 0 likes

    Oops

  • Avatar of Kukulkan Kukulkan Sep 26, 2009 at 06:22 UTC - 0 likes

    Release2 is giving me the following error

    [2009/09/26 00:19:04-316-x1]: BleedingHearts-1.0.$Revision: 2 $\BleedingHearts.lua:75: BleedingHearts requires AceGUI-3.0-SharedMediaWidgets BleedingHearts-1.0.$Revision: 2 $\BleedingHearts.lua:75: in main chunk

  • Avatar of Zeksie Zeksie Sep 21, 2009 at 08:32 UTC - 0 likes

    Yeh, will fix the packager for that shortly.

  • Avatar of npcarter npcarter Sep 16, 2009 at 18:04 UTC - 0 likes

    Beta 1 isn't working for me. On startup, I get the error " ..\AddOns\BleedingHearts\BleedingHearts.lua line 77: Usage: EmbedLibrary(addon, libname, silent, offset): 'libname' - Cannot find a library instance of "AceComm-3.0"."

    There doesn't seem to be an AceComm-3.0 file in the addon's libs sub-directory, and I'm using the version with embedded libraries. Maybe this file got left out?

    Looks like it'll be a great addon when all the bugs get worked out. I've been tossing around the idea of writing something similar myself.

    Last edited Sep 16, 2009 by npcarter
  • 10 comments

Facts

Date created
Sep 10, 2009
Categories
Last update
Mar 04, 2011
Development stage
Abandoned
Language
  • enUS
License
GNU General Public License version 3 (GPLv3)
Downloads
17,595
Recent files
  • A: r24 for 4.0.6 Mar 04, 2011
  • A: r23 for 4.0.1 Oct 22, 2010
  • R: 3.3 Release 1 for 3.3.0 Dec 09, 2009
  • A: r21 for 3.3.0 Dec 09, 2009
  • R: r20 for 3.2.0 Oct 28, 2009

Authors

Relationships

Embedded library
Ace3
AceGUI-3.0-SharedMediaWidgets