Ackis Recipe List

1611 - Addon RAM Soars to over 22 MB Usage and Climbing

ARL Version (ie: 1.0):
2.6.2

ARL Revision:
fbca907

Are you running Skillet/ATSW or any other tradeskill mods?
No

What is the in-game error you received (DON'T INCLUDE A LIST OF ADDONS YOU ARE RUNNING, PLEASE)?
No error is displayed. The game will slow down to 0 FPS, addon memory usage will shoot up to 22 MB and continue climbing. If a garbage cleanup is performed, it will start a 6 MB and then continue increasing memory until WoW is killed (only after the 22 MB problem has occurred first). Normally the addon sits at 4.99 MB Usage.

What did you do with ARL to cause the error/problem?
After logging into the game, I opened the World Map, everything was fine until I moused over one the recipe icons displayed on the world map. The tooltip appeared, and I went to mouse over a second recipe icon on the world map, then the game went from 45 FPS to 0 FPS, the addon usage for this addon went from a standard 4.99 MB to 22 MB and climbing before I performed a garbage collection. Still getting an average of 0 FPS, it went to 6 MB memory and then started climbing in memory usage very rapidly until I used Task Manage to kill the game. The problem is somewhat random, and does not occur all the time. In fact, most of the time everything is fine. Occasionally though, this problem occurs, things go to 0 FPS, memory usage soars, and the only option is to use Task Manager to Kill the game and relog.

Are you running with libraries embedded or disembeded?
From the looks of the TOC file, I believe they are embedded.

How critical is fixing this defect?
Medium-High

Please provide any additional information below:

A Blizzard Forum Thread was created in my attempting to track down the initial cause of the issue, which has over the course of many days, lead me to believe this addon is causing the problem, or at least part of it. If you would like to read the forum thread, it is available at: http://us.battle.net/wow/en/forum/topic/11676478109?page=1

User When Change
resa1983 May 26, 2014 at 18:28 UTC Changed status from New to Declined
aqiruse Feb 19, 2014 at 08:45 UTC Changed description:
  Please provide any additional information below:

+ A Blizzard Forum Thread was created in my attempting to track down the initial cause of the issue, which has over the course of many days, lead me to believe this addon is causing the problem, or at least part of it. If you would like to read the forum thread, it is available at: http://us.battle.net/wow/en/forum/topic/11676478109?page=1
aqiruse Feb 19, 2014 at 08:42 UTC Create

You must login to post a comment. Don't have an account? Register to get one!

Facts

Last updated
May 26, 2014
Reported
Feb 19, 2014
Status
Declined - We decided not to take action on this ticket.
Type
Defect - A shortcoming, fault, or imperfection
Priority
Medium - Normal priority.
Votes
0

Reported by

Possible assignees