Ackis Recipe List

1588 - Alt links is not working

sry my english is not good :(  

ARL Version (ie: 1.0):
2.5.3-2-g42e2e04

Are you running Skillet/ATSW or any other tradeskill mods?
NO

What did you do with ARL to cause the error/problem?
Alt → other profession tradeskill links  → links is not working
use /arl tradelinks → links is not working

Are you running with libraries embedded or disembeded?
embedded

Please provide any additional information below:
http://i4.photobucket.com/albums/y128/sp056845/no_zps15a6185d.jpg

  • no.JPG
    Alt's Links is not working
User When Change
resa1983 Oct 14, 2013 at 00:09 UTC Changed status from New to Invalid
huskysp Oct 01, 2013 at 18:49 UTC

Deleted attachment no.JPG: again :$

huskysp Oct 01, 2013 at 18:48 UTC

Added attachment no.JPG

huskysp Oct 01, 2013 at 18:48 UTC

Added attachment no.JPG

huskysp Oct 01, 2013 at 18:27 UTC Create

You must login to post a comment. Don't have an account? Register to get one!

  • 5 comments
  • Avatar of resa1983 resa1983 Oct 14, 2013 at 00:06 UTC - 0 likes

    @Corwin_MacGregor: Go

    It pulls the character's professions provided the character is in your immediate area (there's problems linking it in trade if they're not in the same area!) - which you can't do if you're on an alt. The only way around that, would be for us to save all 'known' per character, which would most likely increase memory usage unnecessarily.

    Link to Blizzard considering reverting this change: http://us.battle.net/wow/en/forum/topic/9948634812?page=4#65

    Last edited Oct 14, 2013 by resa1983
  • Avatar of Corwin_MacGregor Corwin_MacGregor Oct 13, 2013 at 23:49 UTC - 0 likes

    it is my understanding of the issue that, instead of including a compiled, compressed string bitflagging every available recipe for the profession in the profession link string, they added a GUID reference which pulls down from the character directly. Blizzard didn't really "break" anything, they merely changed the format of the link string. Likewise, the fix is to change ARL to accomodate this change in the format of the link string, and it should work just fine again. After all, blizzard's own code didn't break on this change. If there is uncertainty about the format change, check the FrameXML files for 5.4 for their code that handles it.

    This change was mentioned in the PTR patch notes, but I cannot remember which build, or whether mention of the change made it into the official patch notes.

  • Avatar of resa1983 resa1983 Oct 01, 2013 at 19:01 UTC - 0 likes

    @huskysp: Go

    No problem. I think we're all hoping Blizzard decides to revert their decision. :)

  • Avatar of huskysp huskysp Oct 01, 2013 at 19:00 UTC - 0 likes

    oops.. sorry I don't know Blizzard disabled it witch 5.4 :( Thanks for your explanation :)

    Last edited Oct 01, 2013 by huskysp
  • Avatar of resa1983 resa1983 Oct 01, 2013 at 18:29 UTC - 0 likes

    This is not a bug. Links isn't working because Blizzard changed something with 5.4, which disabled it. If Blizzard reverts this, it'll work again.. Otherwise, it won't.

  • 5 comments

Facts

Last updated
Oct 14, 2013
Reported
Oct 01, 2013
Status
Invalid - This was not a valid report.
Type
Defect - A shortcoming, fault, or imperfection
Priority
Medium - Normal priority.
Votes
1
Component
Backend Functionality

Reported by

Possible assignees