Ackis Recipe List

1580 - Lua error during pet battles on Timeless Isle

ARL Version (ie: 1.0):
2.5.2

ARL Revision:

Are you running Skillet/ATSW or any other tradeskill mods?
No

What is the in-game error you received (DON'T INCLUDE A LIST OF ADDONS YOU ARE RUNNING, PLEASE)?
36x AckisRecipeList-2.5.2\Utilities.lua:83 attempt to index local "guid" (a nil value)
AckisRecipeList-2.5.2\Utilities.lua:83 in function "MobGUIDToIDNum"
AckisRecipeList-2.5.2\Core.lua:409 in function <AckisRecipeList\Core.lua:400
<in C code>
<in C code>
<in C code>
AtlasLootReverse-1.12\libs\LibExtraTip\LibExtraTip.lua:429 in function <AtlasLootReverse\libs\LibExtraTip\LibExtraTip.lua:423
(tail call): ?
<in C code>
<in C code>
<in C code>
<in C code>

Locals:
self = GameTooltip {
 0 = <userdata>
 SetCurrencyByID = <func> =[C]:-1
 SetText = <func> @Gatherer\Swag\LibSwag.lua:408
 Outfitter_OrigSetBagItem = <func> @AtlasLootReverse\libs\..\LibExtraTip.lua:378
 SetHyperlink = <func> @..\Outfitter.lua:7939
 SetGuildBankItem = <func> @AtlasLootReverse\libs\..\LibExtraTip.lua:378
 hasMoney = 1
 Outfitter_OrigSetHyperlink = <func> =[C]:-1
 SetQuestRewardSpell = <func> @AtlasLootReverse\libs\..\LibExtraTip.lua:378
 default = 1
 SetTradeTargetItem = <func> @AtlasLootReverse\libs\..\LibExtraTip.lua:378
 comparing = false
 Show = <func> @TipTac\core.lua:911
 SetPetAction = <func> =[C]:-1
 SetUnitDebuff = <func> =[C]:-1
 SetQuestLogRewardSpell = <func> @AtlasLootReverse\libs\..\LibExtraTip.lua:378
 SetLootItem = <func> @AtlasLootReverse\libs\..\LibExtraTip.lua:378
 SetQuestItem = <func> @AtlasLootReverse\libs\..\LibExtraTip.lua:378
 SetSpellBookItem = <func> @AtlasLootReverse\libs\..\LibExtraTip.lua:378
 FadeOut = <func> @TipTac\core.lua:897
 numMoneyFrames = 1
 SetCurrencyToken = <func> =[C]:-1
 SetUnit = <func> @AtlasLootReverse\libs\..\LibExtraTip.lua:378
 SetInboxItem = <func> @AtlasLootReverse\libs\..\LibExtraTip.lua:378
 SetBuybackItem = <func> @AtlasLootReverse\libs\..\LibExtraTip.lua:378
 shoppingTooltips = <table> {}
 Outfitter_OrigSetInventoryItem = <func> @AtlasLootReverse\libs\..\LibExtraTip.lua:378
 SetMerchantItem = <func> =[C]:-1
 SetQuestLogItem = <func> @AtlasLootReverse\libs\..\LibExtraTip.lua:378
 ClearLines = <func> @Gatherer\Swag\LibSwag.lua:417
 SetUnitBuff = <func> =[C]:-1
 SetTalent = <func> @AtlasLootReverse\libs\..\LibExtraTip.lua:378
 SetTradePlayerItem = <func> @AtlasLootReverse\libs\..\LibExtraTip.lua:378
 SetIconTextureAndText = <func> @TipTacItemRef\core.lua:50
 SetSendMailItem = <func> @AtlasLootReverse\libs\..\LibExtraTip.lua:378
 SetTrainerService = <func> @AtlasLootReverse\libs\..\LibExtraTip.lua:378
 updateTooltip = 0.12499999888241
 SetInventoryItem = <func> @..\Outfitter.lua:7919
 SetMerchantCostItem = <func> =[C]:-1
 ttCount = <unnamed> {}
 SetLootRollItem = <func> @AtlasLootReverse\libs\..\LibExtraTip.lua:378
 SetUnitAura = <func> =[C]:-1
 ttIcon = <unnamed> {}
 SetAuctionSellItem = <func> @AtlasLootReverse\libs\..\LibExtraTip.lua:378
 SetBagItem = <func> @..\Outfitter.lua:7905
 SetShapeshift = <func> @AtlasLootReverse\libs\..\LibExtraTip.lua:378
 ttGradient = <unnamed> {}
 SetTradeSkillItem = <func> @AtlasLootReverse\libs\..\LibExtraTip.lua:378
 SetAuctionItem = <func> @AtlasLootReverse\libs\..\LibExtraTip.lua:378
}
_ = nil
tooltip_unit = "mouseover"
addon = <table> {
 SetDefaultModuleLibraries = <func> @Ace3\..\AceAddon-3.0.lua:398
 InitQuest = <func> @AckisRecipeList\Database\Quest.lua:52
 InitSeasons = <func> @AckisRecipeList\Database\Seasonal.lua:35
 EnableModule = <

What did you do with ARL to cause the error/problem?
Mousing over a pet during petbattles on the Timeless Isle

Are you running with libraries embedded or disembeded?
Embedded

How critical is fixing this defect?
Medium

Please provide any additional information below:

User When Change
resa1983 Sep 13, 2013 at 15:43 UTC
resa1983 Sep 13, 2013 at 03:53 UTC
Agramonia Sep 12, 2013 at 12:01 UTC Create

You must login to post a comment. Don't have an account? Register to get one!

  • 4 comments
  • Avatar of resa1983 resa1983 Sep 13, 2013 at 15:47 UTC - 0 likes

    Apparently, something changed with 5.4.. Any chance you can try the alpha of ARL?

  • Avatar of sidji sidji Sep 13, 2013 at 06:32 UTC - 0 likes

    with only ARL enabled:

    this happens when you mouseover the pets in battle

    Message: Interface\AddOns\AckisRecipeList\Utilities.lua:83 attempt to index local 'guid' (a nil value)
    Time: 09/13/13 08:28:10
    Count: 2
    Stack: Interface\AddOns\AckisRecipeList\Utilities.lua:83 in function `MobGUIDToIDNum'
    Interface\AddOns\AckisRecipeList\Core.lua:409 in function <Interface\AddOns\AckisRecipeList\Core.lua:400
    [C]: ?

    Locals: guid = nil
    (*temporary) = <function> defined =[C]:-1
    (*temporary) = nil
    (*temporary) = nil
    (*temporary) = nil
    (*temporary) = nil
    (*temporary) = "attempt to index local 'guid' (a nil value)"
    tonumber = <function> defined =[C]:-1

    Last edited Sep 13, 2013 by sidji
  • Avatar of resa1983 resa1983 Sep 13, 2013 at 03:43 UTC - 0 likes

    @Agramonia: Go

    Then post that error, as your original one clearly shows the problem being WoW using AtlasLootReverse-1.12's copy of LibExtraTip, instead of ARL's.

    I experienced this error with Enchantrix earlier - disabled Enchantrix and I'm fine. Its not a problem with ARL - its the other mods using old libraries, and its throwing the blame on ARL because ARL adds info to the tooltips.

    Last edited Sep 13, 2013 by resa1983
  • Avatar of Agramonia Agramonia Sep 12, 2013 at 12:56 UTC - 0 likes

    Receiving similar error with AtlasLootReverse removed.

  • 4 comments

Facts

Last updated
Sep 13, 2013
Reported
Sep 12, 2013
Status
Fixed - Developer made requested changes. QA should verify.
Type
Defect - A shortcoming, fault, or imperfection
Priority
Medium - Normal priority.
Votes
0

Reported by

Possible assignees