Archy - Archaeology Assistant

470 - Lua error with 1.8.41

Hello,

Got this Lua error entering the game :

Message: Interface\AddOns\Archy\Archy.lua:1098 attempt to index upvalue 'DIG_SITES' (a nil value)
Time: 03/31/13 20:47:31
Count: 1
Stack: Interface\AddOns\Archy\Archy.lua:1098 in function <Interface\AddOns\Archy\Archy.lua:1078
Interface\AddOns\Archy\Archy.lua:1185 in function <Interface\AddOns\Archy\Archy.lua:1182
Interface\AddOns\Archy\Archy.lua:1207 in function <Interface\AddOns\Archy\Archy.lua:1196
Interface\AddOns\Archy\Archy.lua:2580 in function `?'
Interface\AddOns\Ace3\AceTimer-3.0\AceTimer-3.0.lua:41 in function <Interface\AddOns\Ace3\AceTimer-3.0\AceTimer-3.0.lua:36

It only happens with version n°1.8.41. Don't have any problem with 1.8.40a.

User When Change
Torhal Oct 26, 2014 at 18:15 UTC Changed status from New to Fixed
Strigx Mar 31, 2013 at 18:53 UTC Create

You must login to post a comment. Don't have an account? Register to get one!

  • 5 comments
  • Avatar of Dridzt Dridzt Apr 01, 2013 at 10:08 UTC - 0 likes

    @Strigx: Go

    Yes, I'm afraid the digsite information is half-done for French atm, you'll need to stay with previous Archy version.

    Unfortunately the library that needs the updates is out of my hands so I have to wait for a moderator to repackage it before I can include it in Archy.

  • Avatar of Strigx Strigx Apr 01, 2013 at 09:33 UTC - 0 likes

    I'm playing with french client.

    I always completly exit the game before updating any addon. I tryed the .zip you linked and always have the problem.

    If that's a translation problem in french locale, I can help.

    Edit : It seems my problem can be linked to the one cooli22 reported just 2 hrs after me.

    Last edited Apr 01, 2013 by Strigx
  • Avatar of Dridzt Dridzt Mar 31, 2013 at 21:30 UTC - 0 likes

    Stay with 1.8.40a if you're playing in Spanish/Mexican/Brazilian/Portuguese/French or Korean wow client.

    The Digsite library hasn't yet been updated with mantid digsites for those locales.

    Last edited Apr 01, 2013 by Dridzt
  • Avatar of Dridzt Dridzt Mar 31, 2013 at 20:43 UTC - 0 likes

    I can't reproduce this, either from a cold login or a /reload.

    What language client are you playing on? Try to completely remove the previous version and install Archy manually:
    Download Archy-1.8.41.zip and extract it to your addons folder while exited from the game.

    Start the game up and test if Archy loads properly.

  • Avatar of Dridzt Dridzt Mar 31, 2013 at 20:15 UTC - 0 likes

    Did you completely exit the game after updating?

  • 5 comments

Facts

Last updated
Oct 26, 2014
Reported
Mar 31, 2013
Status
Fixed - Developer made requested changes. QA should verify.
Type
Defect - A shortcoming, fault, or imperfection
Priority
Medium - Normal priority.
Votes
0

Reported by

Possible assignees