Archy - Archaeology Assistant

384 - Digsite distances wrong

What steps will reproduce the problem?
1.Log into the world. I see the Fragment box, but no Digsite location Box.
2.Open the World map, right click to continent view. Close the map.Digsite Location box is now showing, but distances are 9999999
3.Move Character slightly, distances numbers correct themselves but are still incorrect based on my location.

My character is at 51,27 in the Badlands (Hammertoe's Digsite). The Archy Digsite window says the Plaguewood Digsite in EPL is 92 yards away. This is after a reload as well.

What version of the product are you using?
1.8.18
Do you have an error log of what happened?
Producing zero errors

Please provide any additional information below.
Adding a screenshot as well to clarify.
**Edit**  As an additional note, clicking on the Digsite name in the Digsite list, does open the map to the proper zone.

  • Distance_error_no_digsite.jpg
    Digsite Error
  • world_map_showing_zone_digsites.jpg
    World Map showing zone wide ...
  • world_map_showing_continent_digsites.jpg
    Worldmap with Digsites shown on ...
  • reload_ui.jpg
    After a reloadui
  • mouseover_world_digsites.jpg
    Mouseover of minimap button ...
  • worldmap_opened_then_closed_nomovement.jpg
    WorldMap cycled to update ...
  • moved_character_distances_updated_still_incorrect.jpg
    Character moved slightly. ...
User When Change
Torhal Oct 26, 2014 at 18:27 UTC Changed status from New to Fixed
Vis_wowi Mar 13, 2012 at 14:46 UTC

Deleted attachment WoWScrnShot_031212_161014.jpg: duplicate of others

Vis_wowi Mar 13, 2012 at 14:44 UTC

Added attachment moved_character_distances_updated_still_incorrect.jpg

Vis_wowi Mar 13, 2012 at 14:40 UTC

Added attachment worldmap_opened_then_closed_nomovement.jpg

Vis_wowi Mar 13, 2012 at 14:35 UTC

Added attachment mouseover_world_digsites.jpg

Vis_wowi Mar 13, 2012 at 14:34 UTC

Added attachment reload_ui.jpg

Vis_wowi Mar 13, 2012 at 14:19 UTC

Added attachment world_map_showing_continent_digsites.jpg

Vis_wowi Mar 13, 2012 at 14:18 UTC

Added attachment world_map_showing_zone_digsites.jpg

Vis_wowi Mar 13, 2012 at 14:17 UTC

Added attachment Distance_error_no_digsite.jpg

Dridzt Mar 12, 2012 at 23:13 UTC Changed assigned to from Torhal to Dridzt
Vis_wowi Mar 12, 2012 at 20:25 UTC Changed description:
  Producing zero errors

  Please provide any additional information below.
- Adding a couple screenshots as well to clarify
+ Adding a screenshot as well to clarify.
+ **Edit**  As an additional note, clicking on the Digsite name in the Digsite list, does open the map to the proper zone.
Vis_wowi Mar 12, 2012 at 20:21 UTC

Added attachment WoWScrnShot_031212_161014.jpg

Vis_wowi Mar 12, 2012 at 20:19 UTC Create

You must login to post a comment. Don't have an account? Register to get one!

  • Avatar of Vis_wowi Vis_wowi Mar 13, 2012 at 18:18 UTC - 0 likes

    No problem. If you need anymore information or have things you'd like me to try, let me know. I'll be happy to test out things for you.

  • Avatar of Dridzt Dridzt Mar 13, 2012 at 17:22 UTC - 0 likes

    Ok, thank you for the detailed error, this should help a lot.

    Won't be able to investigate it until tomorrow unfortunately but it's appreciated.

    Last edited Mar 14, 2012 by Dridzt
  • Avatar of Vis_wowi Vis_wowi Mar 13, 2012 at 14:48 UTC - 0 likes

    Just received an error when mousing over the minimap button. While having the issue of Digsite distances.

    Message: Interface\AddOns\Archy\Archy.lua:1041: attempt to concatenate local 'continent_name' (a nil value)
    Time: 03/13/12 10:37:15
    Count: 2
    Stack: Interface\AddOns\Archy\Archy.lua:1041: in function `LDBTooltipShow'
    Interface\AddOns\Archy\Archy.lua:1179: in function `OnEnter'
    ...ce\AddOns\Archy\Libs\LibDBIcon-1.0\LibDBIcon-1.0.lua:81: in function <...ce\AddOns\Archy\Libs\LibDBIcon-1.0\LibDBIcon-1.0.lua:72>
    
    Locals: self = <table> {
     UpdatePlayerPosition = <function> defined @Interface\AddOns\Archy\Archy.lua:2645
     SetDefaultModuleLibraries = <function> defined @Interface\AddOns\Archy\Libs\AceAddon-3.0\AceAddon-3.0.lua:383
     SetSinkStorage = <function> defined @Interface\AddOns\Archy\Libs\LibSink-2.0\LibSink-2.0.lua:752
     EnableModule = <function> defined @Interface\AddOns\Archy\Libs\AceAddon-3.0\AceAddon-3.0.lua:348
     modules = <table> {
     }
     CancelTimer = <function> defined @Interface\AddOns\Archy\Libs\AceTimer-3.0\AceTimer-3.0.lua:311
     IterateEmbeds = <function> defined @Interface\AddOns\Archy\Libs\AceAddon-3.0\AceAddon-3.0.lua:458
     SecureHookScript = <function> defined @Interface\AddOns\Archy\Libs\AceHook-3.0\AceHook-3.0.lua:413
     SocketClicked = <function> defined @Interface\AddOns\Archy\Archy.lua:1357
     RawHookScript = <function> defined @Interface\AddOns\Archy\Libs\AceHook-3.0\AceHook-3.0.lua:398
     Printf = <function> defined @Interface\AddOns\Archy\Libs\AceConsole-3.0\AceConsole-3.0.lua:69
     SetDefaultModulePrototype = <function> defined @Interface\AddOns\Archy\Libs\AceAddon-3.0\AceAddon-3.0.lua:425
     GetSinkAce3OptionsDataTable = <function> defined @Interface\AddOns\Archy\Libs\LibSink-2.0\LibSink-2.0.lua:603
     defaultModuleState = true
     IsEnabled = <function> defined @Interface\AddOns\Archy\Libs\AceAddon-3.0\AceAddon-3.0.lua:467
     ScheduleTimer = <function> defined @Interface\AddOns\Archy\Libs\AceTimer-3.0\AceTimer-3.0.lua:276
     DisableModule = <function> defined @Interface\AddOns\Archy\Libs\AceAddon-3.0\AceAddon-3.0.lua:366
     ADDON_LOADED = <function> defined @Interface\AddOns\Archy\Archy.lua:2348
     RegisterMessage = <function> defined @Interface\AddOns\TomTom\libs\CallbackHandler-1.0\CallbackHandler-1.0.lua:118
     UnregisterMessage = <function> defined @Interface\AddOns\TomTom\libs\CallbackHandler-1.0\CallbackHandler-1.0.lua:181
     RegisterBucketEvent = <function> defined @Interface\AddOns\Archy\Libs\AceBucket-3.0\AceBucket-3.0.lua:213
     hooks = <table> {
     }
     db = <table> {
     }
     UpdateDigSiteFrame = <function> defined @Interface\AddOns\Archy\Archy.lua:3192
     SetEnabledState = <function> defined @Interface\AddOns\Archy\Libs\AceAddon-3.0\AceAddon-3.0.lua:440
     Hook = <function> defined @Interface\AddOns\Archy\Libs\AceHook-3.0\AceHook-3.0.lua:277
     enabledState = true
     optionsFrame = <unnamed> {
     }
     RegisterEvent = <function> defined @Interface\AddOns\TomTom\libs\CallbackHandler-1.0\CallbackHandler-1.0.lua:118
     baseName = "Archy"
     SetupOptions = <function> defined @Interface\AddOns\Archy\Config.lua:1453
     ShowArchaeology = <function> defined @Interface\AddOns\Archy\Archy.lua:1209
     SaveFramePosition = <function> defined @Interface\AddOns\Archy\Archy.lua:3492
     IterateModules = <function> defined @Interface\AddOns\Archy\Libs\AceAddon-3.0\AceAddon-3.0.lua:453
     SetFramePosition = <function> defined @Interface\AddOns\Archy\Archy.lua:3462
     RawHook = <function> defined @Interface\AddOns\Archy\Libs\AceHook-3.0\AceHook-3.0.lua:316
     ARTIFACT_COMPLETE = <function> defined @Interface\AddOns\Archy\Archy.lua:2358
     SetDefaultModuleState = <function> defined @Interface\AddOns\Archy\Libs\AceAddon-3.0\AceAddon-3.0.lua:403
     ImportOldStatsDB = <function> defined @Interface\AddOns\Archy\Archy.lua:1590
     ResizeGraphicalDigSiteDisplay = <function> defined @Interface\AddOns\Archy\Archy.lua:3342
     OnEnable = <function> defined @Interface\AddOns\Archy\Archy.lua:2273
     PLAYER_REGEN_DISABLED = <function> defined @Interface\AddOns\Archy\Archy.lua:2539
     ShowDigSiteTooltip = <function> defined @Interface\AddOns\Archy\Archy.lua:3250
     UpdateTracking = <function> defined @Interface
    
  • Avatar of Vis_wowi Vis_wowi Mar 13, 2012 at 14:16 UTC - 0 likes

    Ok, Have just been running with only Archy and TomTom enabled.

    On initial login, the distances and zones for the current continent are correct. I proceeded to the closest location and dug 3 times. The Archy Digsite window did not update locations to show that the Digsite I was just using was now gone. It still listed the now non-existant Digsite as being the most current/closest to me.

    /console reloadui

    Did not fix it, nor cause any updates. Now once the UI reloaded, only the Artifact Frame is shown. Using the minimap button to hide/show the windows does not bring back the Digsite frame. When I mouseover the Minimap button, the current continent, Eastern Kingdoms, is no longer in the list either.

    Open/Close the Blizz map frame.

    Digsite Frame gets populated with sites. All Distance numbers are at 9999999. Nudge my character forward, distances reset and are no longer 999999 but are still incorrect. I'll add screenshots to the ticket to clarify visually.

  • Avatar of Vis_wowi Vis_wowi Mar 13, 2012 at 13:30 UTC - 0 likes

    @Dridzt: Go

    I've been experiencing this behavior since mid version 1.8.XX. I've had Archy installed for much longer, I just haven't restarted my archaeology trades till lately. I seem to have this issue no matter what the version so I believe it is possibly an addon conflict.

    I have also tried several full reinstalls over the past week to make sure I don't have a corrupted file. Full install to me is manually going into the addons directory and deleting the folder/s associated with the addon in question and also doing the same in the WTF folders and deleting all instances of the addons .lua files.

    Looks like server downtime today is going to be minimal so I'll try to narrow down conflicts from my end. And here is a list of my addons as well:

    !BugGrabber
    AckisRecipeList
    Align
    Altoholic
    Altoholic_Achievements
    Altoholic_Agenda
    Altoholic_Characters
    Altoholic_Guild
    Altoholic_Search
    Archy
    AtlasLoot
    AtlasLoot_BurningCrusade
    AtlasLoot_Cataclysm
    AtlasLoot_ClassicWoW
    AtlasLoot_Crafting
    AtlasLoot_Loader
    AtlasLoot_Source
    AtlasLoot_WorldEvents
    AtlasLoot_WrathoftheLichKing
    Auctionator
    Auditor2
    BagBrother 
    Bagnon
    Bagnon_Config
    Bagnon_GuildBank
    BankStack
    BasicChatMods
    Bazooka
    Bazooka_Options
    Bimbo
    BlizzMove
    Broker_Auditor
    Broker_CPU
    Broker_DurabilityInfo
    Broker_Equipment
    Broker_MicroMenu
    Broker_Portals
    Broker_Professions
    Broker_uClock
    Broker_Whereabout
    Buffin
    BuffinTotems
    BugSack
    Castbars
    Clique
    ColorPickerPlus
    CompleteEJ
    DataStore
    DataStore_Achievements
    DataStore_Agenda
    DataStore_Auctions
    DataStore_Characters
    DataStore_Containers
    DataStore_Crafts
    DataStore_Currencies
    DataStore_Inventory
    DataStore_Mails
    DataStore_Pets
    DataStore_Quests
    DataStore_Reputations
    DataStore_Spells
    DataStore_Stats
    DataStore_Talents
    Dominos
    Dominos_Cast
    Dominos_Config
    Dominos_Roll
    Dominos_Totems
    Dominos_XP
    EpicEnchantList
    EpicFoodList
    EpicGemList
    eQueue
    EquipSee
    Factionizer
    FishingAce
    FriendsWithBenefits
    GatherMate2
    GatherMate2_Data
    gBanker
    gnomishauctionshrinker
    Grail
    Grail-Achievements
    Grail-Reputations
    GTFO
    InlineAura
    InlineAura_Config
    InlineAura_Defaults
    InspectFix
    LightHeaded
    LightHeaded_Data_A
    LightHeaded_Data_B
    LightHeaded_Data_C
    LightHeaded_Data_D
    LightHeaded_Data_E
    LightHeaded_Data_NPC
    LightHeaded_Data_QIDDesc
    LightHeaded_Data_QIDNames
    MailOpener
    MinimalArchaeologyBroker - disabled
    mMinimap
    MogIt
    MogIt_Accessories
    MogIt_Armorkinis
    MogIt_Cloth
    MogIt_Companions
    MogIt_Leather
    MogIt_Mail
    MogIt_Mounts
    MogIt_OneHanded
    MogIt_Other
    MogIt_Pets
    MogIt_Plate
    MogIt_Ranged
    MogIt_Sets
    MogIt_TwoHanded
    Monomyth
    nibProfileLoader
    NPCScanEx
    Overachiever
    Overachiever_Tabs
    Overachiever_Trade
    Progress
    Quecho
    Quelevel
    QuestProgressSound
    raiddefstats
    RatingBuster
    Raven
    Raven_Options
    readme-lightheaded.txt
    Reflux
    RollBeast - disabled
    RollMonitor - disabled
    Routes
    ShadowedUF_Indicators
    ShadowedUF_Options
    ShadowedUnitFrames
    Sigma
    Skada
    SkadaCC
    SkadaDamage
    SkadaDamageTaken
    SkadaDeaths
    SkadaDebuffs
    SkadaDispels
    SkadaEnemies
    SkadaHealing
    SkadaPower
    SkadaThreat
    Skillet
    SocialState
    TabardAddict
    TheUndermineJournalGE
    TinyTipWealth
    TipTop
    TomTom
    TomTomLite - disabled
    TotemTimers
    TrackOMatic - disabled
    TradeSkillMaster
    TradeSkillMaster_Accounting
    TradeSkillMaster_AuctionDB
    TradeSkillMaster_Auctioning
    TradeSkillMaster_Crafting
    TradeSkillMaster_Destroying
    TradeSkillMaster_ItemTracker
    TradeSkillMaster_Mailing
    TradeSkillMaster_Shopping
    TradeSkillMaster_Warehousing
    tullaCC
    tullaRange
    tullaRange_Config
    Volumizer
    Who Framed Watcher Wabbit
    Wholly
    _NPCScan
    _NPCScan.Overlay
    
    Last edited Mar 13, 2012 by Vis_wowi: formatting again
  • Avatar of Dridzt Dridzt Mar 13, 2012 at 05:13 UTC - 0 likes

    Ok, bear with me a second.

    Is this new behavior with 1.8.18 or did you have similar issues with previous versions? (if you were using a previous version I mean).

    If you have enabled both frames from Archy options clicking the LDB (or minimap icon they're equivalent) should show/hide both lists: Artifacts + Digsites.

    I'm rather stumped at the moment. Are you using a map addon? (I have tested with default map and Mapster).

    A list of your addons might be useful in this case as I can't think of a way for Archy to show the wrong continent unless some other addon is forcibly setting the map to something other than the current zone.

    If you're feeling extra helpful you could try running with just Archy enabled.
    Copy your WTF folder first before you disable other addons so you don't lose the positions of any that don't save their screen location at saved variables but at the cache.
    Exit the game after you're done with the test and copy over your backup WTF again overwriting and you'll have all your addon configuration intact (what addons you had enabled and their exact settings / positions)

    If you don't want to go to all that trouble it's perfectly understandable btw :-)
    I'll settle for a list of your addons, see if I can make a guess what could be interfering.

  • Avatar of Vis_wowi Vis_wowi Mar 13, 2012 at 02:42 UTC - 0 likes

    I've used the LDB button to toggle the Archy windows. It hasn't changed the behavior or updated the information it shows. When the Digsite Frame is not shown initially, activating and deactivating Archy does nothing but hide/show the Artifact Frame. Opening and closing the World map is the only way I've found to get the Digsite frame to show.

    The Digsite Frame is showing the correct continent. The actual Zones and their corresponding distances are way off. ie my example above. I'm in the center of Badlands, Eastern Kingdoms. Archy is telling me that the next closest Digsite is only 96 yds away in Eastern Plaguelands, also in Eastern Kingdoms. If I move my character 96 yds in any direction, I will still be in the Badlands.

    @Dridzt: Go

  • Avatar of Dridzt Dridzt Mar 12, 2012 at 23:08 UTC - 0 likes

    Instead of toggling the map, try toggling Archy please.

    A quick toggle from the minimap button or keybind should refresh the digsite frame to the proper continent if that happens.

Facts

Last updated
Oct 26, 2014
Reported
Mar 12, 2012
Status
Fixed - Developer made requested changes. QA should verify.
Type
Defect - A shortcoming, fault, or imperfection
Priority
Medium - Normal priority.
Votes
0

Reported by

Possible assignees