AdiBags

173 - Cannot buy anything/withdraw anything.

Can you reproduce this problem? What steps will reproduce it?
1. I turn on AdiBags. I cannot drag, or withdraw any item from bank. I cannot drag/buy items from vendor upon right click.
2.
3.

What is the expected output?
That I can withdraw stuff/buy stuff.

What do you see instead?

What version of the addon are you using?

Do you have an error log of what happened? (Please enable the display of Lua errors or install an error-reporting addon to be sure whether an error happens or not.)

Please provide any additional information below.
Date: 2013-07-15 00:08:49
ID: 1
Error occured in: Global
Count: 1
Message: ..\FrameXML\ContainerFrame.lua line 668:
   attempt to index a nil value
Debug:
   ..\FrameXML\ContainerFrame.lua:668 ContainerFrame_GetExtendedPriceString()
   ..\FrameXML\MerchantFrame.lua:388 MerchantItemButton_OnClick()
   [string "*:OnDragStart"]:1:
      [string "*:OnDragStart"]:1
Locals:
itemButton = AdiBagsItemButton2 {
 NormalTexture = AdiBagsItemButton2NormalTexture {
 }
 bag = 3
 filterName = "Equipment"
 IconQuestTexture = AdiBagsItemButton2IconQuestTexture {
 }
 icon = AdiBagsItemButton2IconTexture {
 }
 IconTexture = AdiBagsItemButton2IconTexture {
 }
 Stock = AdiBagsItemButton2Stock {
 }
 slot = 27
 0 = <userdata>
 UpdateTooltip = <function> defined @Interface\FrameXML\ContainerFrame.lua:798
 count = 1
 Count = AdiBagsItemButton2Count {
 }
 searchOverlay = AdiBagsItemButton2SearchOverlay {
 }
 Cooldown = AdiBagsItemButton2Cooldown {
 }
 SplitStack = <function> defined @Interface\FrameXML\ContainerFrame.lua:655
}
isEquipped = nil
quantity = 1
slot = 27
(*temporary) = nil
(*temporary) = nil
(*temporary) = nil
(*temporary) = nil
(*temporary) = nil
(*temporary) = nil
(*temporary) = nil
(*temporary) = nil
(*temporary) = nil
(*temporary) = nil
(*temporary) = nil
(*temporary) = nil
(*temporary) = nil
(*temporary) = nil
(*temporary) = nil
(*temporary) = nil
(*temporary) = nil
(*temporary) = nil
(*temporary) = nil
(*temporary) = nil
(*temporary) = nil
(*temporary) = nil
(*temporary) = nil
(*temporary) = nil
(*temporary) = nil
(*temporary) = nil
(*temporary) = nil
(*temporary) = nil
(*temporary) = nil
(*temporary) = "attempt to index a nil value"

AddOns:
  Swatter, v5.17.5413 (NeedyNoddy)
  AdiBags, vv1.6.6
  AucAdvanced, v5.17.5413 (NeedyNoddy)
  AucFilterBasic, v5.17.5413 (NeedyNoddy)
  AucFilterOutlier, v5.17.5413.5347(5.17/embedded)
  AucMatchUndercut, v5.17.5413.5364(5.17/embedded)
  AucScanData, v5.17.5413 (NeedyNoddy)
  AucStatHistogram, v5.17.5413 (NeedyNoddy)
  AucStatiLevel, v5.17.5413 (NeedyNoddy)
  AucStatPurchased, v5.17.5413 (NeedyNoddy)
  AucStatSales, v5.17.5413.5376(5.17/embedded)
  AucStatSimple, v5.17.5413 (NeedyNoddy)
  AucStatStdDev, v5.17.5413 (NeedyNoddy)
  AucStatWOWEcon, v5.17.5413.5323(5.17/embedded)
  AucUtilAHWindowControl, v5.17.5413.5347(5.17/embedded)
  AucUtilAppraiser, v5.17.5413.5393(5.17/embedded)
  AucUtilAskPrice, v5.17.5413.5347(5.17/embedded)
  AucUtilAutoMagic, v5.17.5413.5392(5.17/embedded)
  AucUtilCompactUI, v5.17.5413.5400(5.17/embedded)
  AucUtilEasyBuyout, v5.17.5413.5347(5.17/embedded)
  AucUtilFixAH, v5.17.5413 (NeedyNoddy)
  AucUtilItemSuggest, v5.17.5413.5365(5.17/embedded)
  AucUtilPriceLevel, v5.17.5413.5365(5.17/embedded)
  AucUtilScanButton, v5.17.5413.5403(5.17/embedded)
  AucUtilScanFinish, v5.17.5413.5347(5.17/embedded)
  AucUtilScanProgress, v5.17.5413.4979(5.17/embedded)
  AucUtilScanStart, v5.17.5413.5347(5.17/embedded)
  AucUtilSearchUI, v5.17.5413.5373(5.17/embedded)
  AucUtilSimpleAuction, v5.17.5413.5388(5.17/embedded)
  AucUtilVendMarkup, v5.17.5413.4828(5.17/embedded)
  AutoVendor, v0.22
  Babylonian, v5.1.DEV.332(/embedded)
  BadBoy, v12.041
  BeanCounter, v5.17.5413 (NeedyNoddy)
  Configator, v5.1.DEV.344(/embedded)
  DebugLib, v5.1.DEV.337(/embedded)
  HealBot, v5.3.0.6
  HealBotTips, v5.3.0.6
  LibExtraTip, v5.12.DEV.350(/embedded)
  Overachiever, v0.72
  Recount, v
  SlideBar, v5.17.5413 (NeedyNoddy)
  Stubby, v5.17.5413 (NeedyNoddy)
  TidyPlates, v6.11.3
  TidyPlatesGraphite, v
  TidyPlatesGrey, v
  TidyPlatesNeon, v
  TidyPlatesQuatre, v
  TidyPlatesHub, v
  TidyPlatesWidgets, v
  TipHelper, v5.12.DEV.351(/embedded)
  BlizRuntimeLib_enUS v5.3.0.50300 <us>
  (ck=7dc)

User When Change
Adirelle Oct 20, 2013 at 08:30 UTC Changed status from Waiting to Invalid
Adirelle Jul 17, 2013 at 06:39 UTC
jrsauerland Jul 15, 2013 at 04:11 UTC Create

You must login to post a comment. Don't have an account? Register to get one!

  • 1 comment
  • Avatar of Adirelle Adirelle Jul 17, 2013 at 06:39 UTC - 0 likes

    I can't reproduce this bug. Does it happen with only certain merchants ? Does it happen when AdiBags is the only addon loaded ? Are you doing something else that could change the bag content when the bug happens ?

  • 1 comment

Facts

Last updated
Oct 20, 2013
Reported
Jul 15, 2013
Status
Invalid - This was not a valid report.
Type
Defect - A shortcoming, fault, or imperfection
Priority
Medium - Normal priority.
Votes
0

Reported by

Possible assignees